It is currently Tue May 18, 2021 8:14 am

All times are UTC - 8 hours [ DST ]

Forum rules

Please, keep discussions on topic and in the right forum. The start menu topics go into the Classic Start Menu forum, etc. This makes it easier for people to locate topics they are looking for.
If you get a satisfactory response to your question, please mark the topic as "solved". Click the green √ button in the bottom-right of the post.

Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Fri Aug 12, 2016 8:07 pm 

Joined: Fri Oct 18, 2013 9:03 pm
Posts: 116
Hi, Im sorry if this is a newb-ish question as Im new to skinning, but I'm using the latest portable resource hacker 4.2.5 & latest version of classic shell 4.3.0 and would like to test out the new feature , emblems.

I'm not sure if it matters if I use the portable version or not. I'm trying to add an emblem to either the midnight.skin7 file, or the metallic.skin7. I've read the current skinning tutorial, and I can't seem to find the answer Im looking for there.

This is what I've added to under the 'second column' part. I've compiled, saved, and moved my skin from the desktop to the classic shell main skin folder. It does show up as an option for skins.


I put on classic shell skin debugging. This gets an error of resource 57 not found. Also, it defaults to the 'no skin' option.
I've clicked the 'add binary or image resource' button in resource hacker, and the resource picture is there.

Clicking that button either makes a new 'folder' called PNG for .png files, or RCData for .jpg pictures in resource hacker.

I can't seem to place my resource 57 image under the folder 'IMAGE'. It's also not possible to rename the PNG or RCData folder to 'IMAGE' so that my resource 57 picture is under that folder.

Other things to note:

I've also put these settings because I don't understand how to make an emblem show.



The menu does show with these options. No errors are shown, but there is no emblem displayed.

How can I make this work to display emblems? Thanks! Any help is much appreciated =)

Reply with quote  
PostPosted: Sat Aug 13, 2016 5:45 pm 
User avatar

Joined: Thu Jun 13, 2013 12:07 pm
Posts: 1187
I don't know enough.
It worked for me in Metroid and K20 skins:



Ivo said it looks for the bitmap number first, if it can't find, it goes to image number.

I find to make work, copy exactly the way Ivo did for the image folder in his Metallic skin.
Make sure .png for image folder, not .bmp
I put the 1033 language number in there too.
And don't have a bitmap and image number with same number.
The second column is usually the main right side.

I used old Resource Hacker 3.6. Maybe new version works differently.
I know a newer version did not work with search function. That's why I reverted.
From what I understand, an emblem is just another image layer that can float above the menu, with menu text above it.

Good luck. :)

Screenshot (54).jpg
Screenshot (54).jpg [ 52.65 KiB | Viewed 6823 times ]
Reply with quote  
PostPosted: Wed Aug 17, 2016 2:09 pm 

Joined: Fri Oct 18, 2013 9:03 pm
Posts: 116
Hi, thanks for your reply, it's much appreciated. I wouldn't of known what to do if you didn't tell me about resource hacker 3.6. The latest resource hacker 4.2.5 doesn't support changing the resource type for .png files. I also did what you said for keeping the emblem text the same way as Ivo had it.

I've made a Windows 10 start menu on Windows 8 now with the new emblems feature.
It can be seen here:


Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 8 hours [ DST ]

Who is online

Users browsing this forum: No registered users and 44 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group, Almsamim WYSIWYG Classic Shell © 2010-2016, Ivo Beltchev.
All right reserved.