It is currently Wed Dec 13, 2017 2:21 am

All times are UTC - 8 hours [ DST ]


Forum rules


Before posting a bug report or a feature request, search the forum for an older post on the same topic. If you are reporting a crash, try capturing a crash dump. You can find instructions here: How to capture crash dumps



Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Mon Oct 27, 2014 9:20 am 
Offline

Joined: Mon Oct 27, 2014 9:10 am
Posts: 8
Lines which links nodes in tree view conflicts with items icons - see screenshot.
Win10 Build 9841, 32 bit, in VMware player 6.0.3 build-1895310


Attachments:
win10classExp.png
win10classExp.png [ 12.86 KiB | Viewed 4034 times ]
Top
 Profile  
Reply with quote  
PostPosted: Sun Apr 12, 2015 10:11 pm 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5340
This happens if you are using the 'Windows XP Classic' navigation pane style. It was not compatible with Windows 10 with the default tree item spacing so it was removed in the newest version.

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and Classic Shell tester.


Top
 Profile  
Reply with quote  
PostPosted: Mon Apr 13, 2015 1:53 am 
Offline

Joined: Mon Oct 27, 2014 9:10 am
Posts: 8
But these vertical lines are very good - it was easier to know which folder is under which folder...
Folder icon could be drawn with greater distance from [+], or be "empty" (white square), but please, do not remove WinXP classic.


Top
 Profile  
Reply with quote  
PostPosted: Mon Apr 13, 2015 2:42 am 
Offline
User avatar

Joined: Wed Apr 02, 2014 5:49 am
Posts: 31
'Windows XP Classic' is my favorite pane style too.
Hope you'll be able to make this work for Win10.


Top
 Profile  
Reply with quote  
PostPosted: Mon Apr 13, 2015 4:53 am 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5340
It worked only if you set the "tree item spacing" to 4 or higher. Otherwise, with tree spacing set to any value lower than 4, the icons got all corrupted in 'Windows XP Classic' nav pane style due to a Windows 10 bug.

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and Classic Shell tester.


Top
 Profile  
Reply with quote  
PostPosted: Mon Apr 13, 2015 7:19 am 
Offline
User avatar

Joined: Wed Apr 02, 2014 5:49 am
Posts: 31
GauravK wrote:
It worked only if you set the "tree item spacing" to 4 or higher. Otherwise, with tree spacing set to any value lower than 4, the icons got all corrupted in 'Windows XP Classic' nav pane style due to a Windows 10 bug.

Should be an extremely simple fix then..
As a workaround, just make Classic shell change this value automatically when you choose 'Windows XP Classic' style! :)


Top
 Profile  
Reply with quote  
PostPosted: Mon Apr 13, 2015 8:14 am 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5340
According to Ivo (the developer), "It is something that can't be depended on. The metrics in the tree depend on many external factors – DPI, text size, icon size. The root cause of the problem is that for some reason Windows 10 sets the line height to be 8 pixels and then uses 3 lines to represent each item. In that mode the tree control can’t correctly draw the icon, so Explorer draws it manually. However that interferes with the way the control draws its lines."

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and Classic Shell tester.


Top
 Profile  
Reply with quote  
PostPosted: Mon Apr 13, 2015 12:11 pm 
Offline
User avatar

Joined: Wed Apr 02, 2014 5:49 am
Posts: 31
GauravK wrote:
According to Ivo (the developer), "It is something that can't be depended on. The metrics in the tree depend on many external factors – DPI, text size, icon size. The root cause of the problem is that for some reason Windows 10 sets the line height to be 8 pixels and then uses 3 lines to represent each item. In that mode the tree control can’t correctly draw the icon, so Explorer draws it manually. However that interferes with the way the control draws its lines."

That's too bad.
Guess we'll have to settle for one of the other styles under Win10 then. :(

The only thing I find really annoying with Classic Shell under Win8.1, is the strange behavior related to keyboard accelerators in the start menu:
viewtopic.php?f=12&t=2429/
When scrolling through the start menu, accelerators only work for the current sub-menu, instead of the active one.
I don't care what anyone says..
This is NOT consistent with the way accelerators has worked in M$'s start menus!
I though that I would get used to it, but I can't..
Too many years of using the accelerators in M$'s start menus I guess.
I'm not gonna bump that thread again though, since Ivo has clearly stated that the behaviour is by design.
Still, it would be nice if we were able to change this behaviour from Classic Shell's settings.


Top
 Profile  
Reply with quote  
PostPosted: Sun Jun 28, 2015 1:09 pm 
Offline

Joined: Mon Oct 27, 2014 9:10 am
Posts: 8
But Classic Shell could allow to switch to 'Windows XP Classic', with warning: "could looks strange" :)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group, Almsamim WYSIWYG Classic Shell © 2010-2016, Ivo Beltchev.
All right reserved.