Classic Shell
http://classicshell.net/forum/

Submenu folder icons
http://classicshell.net/forum/viewtopic.php?f=7&t=8484
Page 1 of 1

Author:  balmforthk [ Tue Sep 04, 2018 7:38 am ]
Post subject:  Submenu folder icons

Hi,
I configured Classic Shell on my Windows 7 system when I first installed it about 3 years ago. I've installed Classic shell on a Windows 10 VM but unfortunately the submenu folders don't look the same and I can't remember how I configured them or even if I configured them.
I've attached a couple of pictures to show the difference.
Does anyone know how to change the submenu folder icons please?
Thanks,

Attachments:
Windows10Folders-2.jpg
Windows10Folders-2.jpg [ 19.43 KiB | Viewed 8165 times ]
Windows7Folders.png
Windows7Folders.png [ 3.27 KiB | Viewed 8165 times ]

Author:  juniper7 [ Tue Sep 04, 2018 12:15 pm ]
Post subject:  Re: Submenu folder icons

I don't see any way to change submenu icons in CSM settings.


Either a program replaced a system folder ico, or it was manually done.
If ReactOS was made from WinNT, I don't have the icons for that system.

I did find a few similar looking icons in XP in Explorer.exe and shell32.dll files.
Only the 16-pixel size matches up to your screenshot. Bigger sizes look the newer type.

Which one to change out, I don't know. For sure make a copy of original file just in case.

Here is some info:

https://www.askvg.com/tip-how-to-modify ... n-windows/


https://www.wikihow.com/Change-the-Icon-for-an-Exe-File



You might have to delete the thumbnail cache and restart to get the different folder icon to show up:

https://www.tenforums.com/tutorials/565 ... -10-a.html


I have not done something like this in a while. Last time was when WindowBlinds deleted
a bunch of original system icons and left in icons from a disused WB skin.

Attachments:
From XP folder icons.zip [26.93 KiB]
Downloaded 366 times

Author:  balmforthk [ Wed Sep 05, 2018 5:41 am ]
Post subject:  Re: Submenu folder icons

Hi,
Thanks for your suggestions. I've been using the shell32.dll, renamed to shell32-xp.dll, from an XP system, and using the following articles to change the open and closed folder icons and these worked fine with File Explorer, where they are used.
http://www.sevenforums.com/tutorials/23825-folder-icon-change-windows-7-default-folder-icon.html
http://www.sevenforums.com/tutorials/23878-open-folder-icon-change.html
However, with Classic Shell, it seems to pick up the "wrong" icon for stuff that was installed before I made the above changes and the "right" icon for stuff that was installed after the above changes were made. See attached picture.
You can right click on the menu item, e.g. Maintenance in the attachment, click Properties->Customize->Change Icon, then browse for the shell32-xp.dll I mentioned earlier and pick the correct icon but that's a lot of work if you have many subfolders and many levels of subfolder. I think I must have done it a different way in the past but I can't remember.
Regards,






juniper7 wrote:
I don't see any way to change submenu icons in CSM settings.


Either a program replaced a system folder ico, or it was manually done.
If ReactOS was made from WinNT, I don't have the icons for that system.

I did find a few similar looking icons in XP in Explorer.exe and shell32.dll files.
Only the 16-pixel size matches up to your screenshot. Bigger sizes look the newer type.

Which one to change out, I don't know. For sure make a copy of original file just in case.

Here is some info:

https://www.askvg.com/tip-how-to-modify ... n-windows/


https://www.wikihow.com/Change-the-Icon-for-an-Exe-File



You might have to delete the thumbnail cache and restart to get the different folder icon to show up:

https://www.tenforums.com/tutorials/565 ... -10-a.html


I have not done something like this in a while. Last time was when WindowBlinds deleted
a bunch of original system icons and left in icons from a disused WB skin.


Attachments:
Windows10Folders-4.jpg
Windows10Folders-4.jpg [ 31.35 KiB | Viewed 8130 times ]

Author:  Ivo [ Wed Sep 05, 2018 8:04 am ]
Post subject:  Re: Submenu folder icons

Try clearing the cached icons. From the Settings click on Backup, then Clear cached information.

Author:  balmforthk [ Wed Sep 05, 2018 8:58 am ]
Post subject:  Re: Submenu folder icons

Hi, yes that worked. Thanks for your help.
Ivo wrote:
Try clearing the cached icons. From the Settings click on Backup, then Clear cached information.

Page 1 of 1 All times are UTC - 8 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/