It is currently Sat Dec 16, 2017 7:57 am

All times are UTC - 8 hours [ DST ]


Forum rules


Please, keep discussions on topic and in the right forum. The start menu topics go into the Classic Start Menu forum, etc. This makes it easier for people to locate topics they are looking for.
If you get a satisfactory response to your question, please mark the topic as "solved". Click the green √ button in the bottom-right of the post.



Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Wed Nov 29, 2017 7:42 am 
Offline

Joined: Tue Jan 31, 2017 3:47 am
Posts: 12
Hey all,

At the start and middle of this year, I posted on here about issues I was having with Classic Shell crashing explorer on Windows 10. A lot of others chimed in too, saying that they were having similar issues.

I was using 4.3.0 but I've now updated to 4.3.1 and I'm miffed to say that I'm still getting this problem. It seems slightly less frequent than before but on an average day, classic shell will still crash explorer 2 or 3 times - requiring you to manually restart explorer.exe via task manager. I'm still very keen to use Classic Shell because, despite this issue, I really like it - this is why it annoys me so much because everything else about Classic Shell is awesome.

For anyone getting similar freezes/crashes - if you open Task manager while Classic Shell is running, you can almost watch the problem occuring. Go to the 'Performance' tab of task manager --> Open Resource Monitor. With the Resource Monitor open, sort by threads and you should see explorer.exe. While Classic Shell is open, these threads will slowly rise over the course of a few hours (typically) until they hit around 820-830, at which point explorer will then freeze. The problem is exasperated the more windows and programs you open. It's like a memory leak or something.

Admittedly I haven't tried Windows 10 versions 1703/1709 as we're currently using 1607 (due to being a school and cautious about potential bugs and issues).

Is there any way round this? We didn't really get anywhere last year and I abandoned using Classic Shell in the end. I did submit a log but it never really got anywhere I don't think.

Thanks very much


Top
 Profile  
Reply with quote  
PostPosted: Sat Dec 02, 2017 6:07 am 
Offline

Joined: Mon Nov 20, 2017 9:36 am
Posts: 3
Have you tried to set File Explorer to "Launch folder windows in a separate process" and restart the PC?
I'm on Win10 1703 and it's my experience that this fix didn't work before on ClassicShell 4.3.0 and earlier but it works now on ClassicShell 4.3.1

The only downside to this setting is that now frequently File Replace dialogs will pop under other File Explorer windows and go unnoticed...


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group, Almsamim WYSIWYG Classic Shell © 2010-2016, Ivo Beltchev.
All right reserved.