It is currently Sun Dec 17, 2017 6:23 pm

All times are UTC - 8 hours [ DST ]


Forum rules


Please, keep discussions on topic and in the right forum. The start menu topics go into the Classic Start Menu forum, etc. This makes it easier for people to locate topics they are looking for.
If you get a satisfactory response to your question, please mark the topic as "solved". Click the green √ button in the bottom-right of the post.



Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Tue Oct 24, 2017 3:59 pm 
Offline

Joined: Fri Oct 11, 2013 7:37 am
Posts: 22
I'm using Classic Shell 4.3.1 . . . I have found that in order for this setting in the Registry to work, which will make NumLock "on":

HKEY_USERS \ .DEFAULT \ Control Panel \ Keyboard \ InitialKeyboardIndicators
Default: 2147483648
Change it to: 2147483650

It's necessary to [un-check] "Enable hybrid shutdown":

Classic Start Menu Settings / Main Menu / [un-check] Enable hybrid shutdown . . . (Is this primarily for Win 8, which is not used much today? Maybe it should be un-checked by default?)

Please see this page for the full story:

With this BIOS setting, why isn't NumLock enabled / "On" when it gets to the Login screen? . . . https://h30434.www3.hp.com/t5/Desktop-Software-and-How-To-Questions/With-this-BIOS-setting-why-isn-t-NumLock-enabled-quot-On/m-p/6186353#M68595


Top
 Profile  
Reply with quote  
PostPosted: Tue Oct 24, 2017 9:16 pm 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5340
Windows 8/8.1/10 all have hybrid shutdown on by default. Classic Shell simply follows the default Windows setting.

The Reg values have changed across each Windows version: https://winaero.com/blog/enable-numlock ... indows-10/ I don't know what they are for the latest Windows 10 release. It might even be broken or not work at all at the login screen. A lot of things are broken in Windows 10.
You can change the state of numlock with a simple VBScript placed in your Startup folder. Copy and paste the following in Notepad and save as a "Numlock.vbs" file. Copy it to your Startup folder at C:\Users\<YOUR USER NAME>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

set WshShell = CreateObject("WScript.Shell")
WshShell.SendKeys "{NUMLOCK}"

This script will of course only change the state of Numlock after logging in, not at the sign in screen. Try using Group Policy to set it as a "Startup script" and see if it works.

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and Classic Shell tester.


Top
 Profile  
Reply with quote  
PostPosted: Wed Oct 25, 2017 8:07 am 
Offline

Joined: Fri Oct 11, 2013 7:37 am
Posts: 22
. . . Windows 8/8.1/10 all have hybrid shutdown on by default. Classic Shell simply follows the default Windows setting.

I don't think it's on by default in Win 10, because:

a.) when I shutdown with the Windows "Power" button / re-booted / the Registry setting worked

b.) when I un-checked "Enable Hybrid Shutdown" in CS / re-booted / the Registry setting worked . . . but, the Registry setting did "not" work, when CS "Hybrid Shutdown" was enabled.

. . . It might even be broken or not work at all at the login screen. A lot of things are broken in Windows 10.

I got the above to work, so this Registry setting is not broken, it only doesn't work if "Enable Hybrid Shutdown" is checked in CS

. . . You can change the state of numlock with a simple VBScript placed in your Startup folder

Thank you! But I fixed this a lot easier as described above - the full explanation is on the HP page (link above).

. . . This script will of course only change the state of Numlock after logging in, not at the sign in screen.

But that's where I want it on, and a lot of other people do too . . . fixed, as described above

. . . Try using Group Policy to set it as a "Startup script" and see if it works.

Fixed a lot easier, as described above.

I'm just posting this, because I think you might want to consider how many CS users there are, that want to use that NumLock "on" Registry setting, it doesn't work, and they have no idea why.

I think that "Enable Hybrid Shutdown" should be un-checked by default in future versions of CS for this reason.

Also, I didn't see any significantly lower speed with it off. Maybe that's due to my system, with a C: SSD drive.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group, Almsamim WYSIWYG Classic Shell © 2010-2016, Ivo Beltchev.
All right reserved.