It is currently Sat Dec 16, 2017 1:45 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Wed Aug 05, 2015 5:59 pm 
Offline

Joined: Mon Apr 08, 2013 3:13 pm
Posts: 127
Has anyone else seen an occasional several second delay in opening the Classic View Start Menu on Win 10 after the Start button is pressed?

I have SSDs, so there's no chance of it being a disk spinning up. Nothing should really be taking several seconds to become ready.

Can't say I ever experienced that on Win 8.1 or older.

-Noel


Top
 Profile  
Reply with quote  
PostPosted: Wed Aug 05, 2015 6:15 pm 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 5310
Try to capture a series of dumps as it happens.
Also if you can run Process Monitor to see what files or registry keys are being accessed by the explorer process.


Top
 Profile  
Reply with quote  
PostPosted: Thu Aug 06, 2015 1:10 pm 
Offline

Joined: Mon Apr 08, 2013 3:13 pm
Posts: 127
Hi Ivo,

I didn't think there was much chance I'd be able to capture the problem, but incredibly I just managed it. I remembered to start Procmon just prior to pressing the Start orb, saw a several second delay, then stopped the event capture.

You can download the Procmon event list here:

Filtered only for Explorer.exe (5 MB):
http://Noel.ProDigitalSoftware.com/temp ... nDelay.PML

With all events (39 MB):
http://Noel.ProDigitalSoftware.com/temp ... Events.PML

-Noel


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 07, 2015 7:38 am 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 5310
Verify that if you turn off the "Show recent Metro apps" setting the problem goes away.
The next version will have much faster recent apps list.


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 07, 2015 11:29 pm 
Offline

Joined: Mon Apr 08, 2013 3:13 pm
Posts: 127
That was turned off long ago.

I should clarify... That particular box was actually checked, but the Show recent or frequent programs setting was set to "Don't show", so the box was grayed out. I've unchecked it now and returned back to the "Don't show" setting, and will report back if the timing seems better.

-Noel


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 08, 2015 9:11 am 
Offline

Joined: Mon Apr 08, 2013 3:13 pm
Posts: 127
Nope, unchecking the box even though it was disabled at a higher level made no difference.

-Noel


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 08, 2015 9:34 am 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 5310
I don't see anything immediately obvious from the PML file. Try these things to see if any of them makes a difference:
1) Use the Classic Shell button instead of the Windows 10 button, or vice versa
2) Hide the Search button in the taskbar (or show it if it is hidden)
3) Disable Aero Glass

Also keep a Process Explorer opened in admin mode and look for another process that may be doing something expensive from time to time - like AV software or a service or something.


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 08, 2015 5:01 pm 
Offline

Joined: Mon Apr 08, 2013 3:13 pm
Posts: 127
OK, I'll try those things. It's a bit slow to test since it doesn't happen all the time. My normal setup:

ClassicShell button is mine, derived from your shell.
AV software is Microsoft's Defender.
Running processes minimized. When nothing much is running, they number in the mid to high 40s.
Search button / field in the taskbar is off.
Aero Glass is on.
UAC is off.

I have a suspicion it may have to do with my running UAC-disabled. Unfortunately we've moved past where Microsoft even remotely supports operating in that manner. If a delay is the worst thing that results from that, I can probably live with it.

-Noel


Top
 Profile  
Reply with quote  
PostPosted: Mon Jul 04, 2016 7:41 am 
Offline

Joined: Wed Aug 26, 2015 6:13 am
Posts: 11
Location: France
I'm not sure if it's right to post in an old thread on this forum, but as I've noticed something about this issue I see no point in creating a new one.

I've had this delay too when showing the Start Menu (4.2.7).
I've tested several things, and found out that showing the frequent programs with Show recent Metro Apps ticked causes the menu to take a long time to open. Showing recent programs with Show recent Metro Apps ticked makes it a bit faster, but there's still a delay. Disabling Show recent Metro Apps removes that delay almost completely in both cases.

To make it even faster, it's also possible to just show nothing (I mean, no recent/frequent programs), also to disable jumplists, and sort the main menu only the first time. But these ones only make light improvements, the main reason for the delay is indeed the recent Metro Apps. At least for me.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group, Almsamim WYSIWYG Classic Shell © 2010-2016, Ivo Beltchev.
All right reserved.