It is currently Sat Oct 19, 2019 8:34 am

All times are UTC - 8 hours [ DST ]


Forum rules


Before posting a bug report or a feature request, search the forum for an older post on the same topic. If you are reporting a crash, try capturing a crash dump. You can find instructions here: How to capture crash dumps



Post new topic Reply to topic  [ 17 posts ] 
Author Message
PostPosted: Tue Nov 22, 2016 10:41 am 
Offline

Joined: Tue Nov 22, 2016 10:25 am
Posts: 10
Running V4.3.0 on Windows 10: Every time I first open Windows Explorer the "Classic Shell Update" dialog pops up saying there is a new Version available. When I click on the dialog, it says I am running the latest version. Very annoying!


Top
 Profile  
Reply with quote  
PostPosted: Tue Nov 22, 2016 7:17 pm 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5352
When the popup appears, click on it and choose the option to not notify you again.

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and helped a little with Classic Shell's testing and usability/UX feedback.


Top
 Profile  
Reply with quote  
PostPosted: Tue Nov 22, 2016 8:32 pm 
Offline

Joined: Tue Nov 22, 2016 10:25 am
Posts: 10
The is no option to "not notify" me.

Unless you mean to uncheck the "Automatically check for a new version" box, which is NOT what I want either.

The needed option (and how I thought it was supposed to work) is to check for a new version, but only notify me if one is available.

That's why I thought it was a 'bug'!


Top
 Profile  
Reply with quote  
PostPosted: Wed Nov 23, 2016 4:31 am 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5352
OK the option to not notify again is not appearing because the update component seems to be confused with the version. Just open File Explorer and go to C:\ProgramData\ClassicShell. Delete the file update.ver. Now it should not show the update notification unless a new version is actually released. If it still shows you, then clicking on it should show the option to not notify again.

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and helped a little with Classic Shell's testing and usability/UX feedback.


Top
 Profile  
Reply with quote  
PostPosted: Wed Nov 30, 2016 12:59 pm 
Offline

Joined: Tue Nov 22, 2016 10:25 am
Posts: 10
I can't get it to stop!

I deleted Classic Shell from the system, then re-installed V4.3.0

Same problem.


Top
 Profile  
Reply with quote  
PostPosted: Wed Nov 30, 2016 9:06 pm 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5352
Did you delete update.ver from C:\ProgramData\ClassicShell? Following the troubleshooting steps is important if you want to fix your issue

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and helped a little with Classic Shell's testing and usability/UX feedback.


Top
 Profile  
Reply with quote  
PostPosted: Wed Nov 30, 2016 10:24 pm 
Offline

Joined: Tue Nov 22, 2016 10:25 am
Posts: 10
Yes (to be technically correct, I renamed it).

And the re-installation recreated the update.ver file.


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 01, 2016 12:18 am 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5352
Then the installed version stored in the Registry is not being updated for some reason:

In the Registry at HKEY_LOCAL_MACHINE\SOFTWARE\IvoSoft\ClassicShell, the value data of the "Version" DWORD value has to be '40300' in Decimals.

Also, in the Registry at HKEY_CURRENT_USER\Software\IvoSoft\ClassicShell, you could try deleting the values LastUpdateTime and LastUpdateVersion. The values will be re-created with their correct value data when the update check is done again.

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and helped a little with Classic Shell's testing and usability/UX feedback.


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 01, 2016 10:09 am 
Offline

Joined: Tue Nov 22, 2016 10:25 am
Posts: 10
The HKEY_LOCAL_MACHINE\SOFTWARE\IvoSoft\ClassicShell\Version IS 40300 (decimal)

The HKEY_CURRENT_USER\Software\IvoSoft\ClassicShell\LastUpdateVersion was 40300 (hex).


However, I deleted both HKEY_CURRENT_USER\Software\IvoSoft\ClassicShell LastUpdateTime and LastUpdateVersion, per your suggestion.

Same problem.


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 01, 2016 10:18 am 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 5333
Download the Classic Shell Utility from here: http://www.classicshell.net/downloads/
Run it, save a system log and send it to me


Top
 Profile  
Reply with quote  
PostPosted: Wed Dec 07, 2016 12:55 pm 
Offline

Joined: Tue Nov 22, 2016 10:25 am
Posts: 10
Sorry for the delay (never got a notify msg), I just found you response message.

Downloaded from you link, uninstalled CS, installed from download.
Ran CS - verified problem still occurs.


Saved the Event Viewer 'System log' events. Not sure if this is what you want or not. It is attached.

UPDATE:
Actually, it is not attached. getting error 'extension .evtx' is not allowed.


Top
 Profile  
Reply with quote  
PostPosted: Wed Dec 07, 2016 12:56 pm 
Offline

Joined: Tue Nov 22, 2016 10:25 am
Posts: 10
Can't attach the file... Now what?


Top
 Profile  
Reply with quote  
PostPosted: Wed Dec 07, 2016 1:00 pm 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 5333
No, download the "Classic Shell Utility" from the page. it has its own logging functionality.

If you can't or don't want to attach the log file here, drop it in this folder: http://www.mediafire.com/filedrop/filed ... ca5151aa1d


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 08, 2016 10:16 pm 
Offline

Joined: Tue Nov 22, 2016 10:25 am
Posts: 10
Oops, my mistake.

Log attached.


Attachments:
16)12_09-ClassicShellSystem.txt [191.44 KiB]
Downloaded 214 times
Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 08, 2016 10:19 pm 
Offline

Joined: Tue Nov 22, 2016 10:25 am
Posts: 10
Try #2


Attachments:
File comment: 12/09/16 System log
16)12_09-ClassicShellSystem.txt [191.44 KiB]
Downloaded 214 times
Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 08, 2016 10:27 pm 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 5333
You have a mix of files from version 4.3.0 and 4.2.7.
Use the Classic Shell Utility again, and this time choose the manual uninstall option. Restart the computer, then make sure the folder D:\Program Files\Classic Shell\ is gone. If not, delete it manually.
Then install version 4.3.0


Top
 Profile  
Reply with quote  
PostPosted: Sun Dec 11, 2016 1:28 pm 
Offline

Joined: Tue Nov 22, 2016 10:25 am
Posts: 10
That took care of the problem.

Thank you so much!


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group, Almsamim WYSIWYG Classic Shell © 2010-2016, Ivo Beltchev.
All right reserved.