It is currently Tue Aug 11, 2020 5:59 pm

All times are UTC - 8 hours [ DST ]


Forum rules


Before posting a bug report or a feature request, search the forum for an older post on the same topic. If you are reporting a crash, try capturing a crash dump. You can find instructions here: How to capture crash dumps



Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Mon Sep 12, 2016 9:05 am 
Offline

Joined: Mon Sep 12, 2016 8:46 am
Posts: 3
Updated to Win 10 Anniv Update, which uninstalled ClassicShell so...you get the rest. Dumb Windows.

Wanted to run cleanmgr.exe as an admin via the context menu option, UAC prompts, I accidentally tapped on No, and my menu won't open ever again, ever.

To fix this one has to restart explorer.exe (Windows Explorer) either via command-line or Task Manager.


This problem did not occur to me on the November Update and an older version of ClassicShell.

FYI I am running ClassicShell 4.3, clean copy :)


Top
 Profile  
Reply with quote  
PostPosted: Mon Sep 12, 2016 9:08 am 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 5333
Weird. I don't get a UAC prompt when running cleanmgr.exe, even if I run it as admin.
But running cmd.exe as admin, then declining the prompt, didn't cause any problems with the start menu.
Can you make the problem happen again?


Top
 Profile  
Reply with quote  
PostPosted: Mon Sep 12, 2016 11:36 am 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5353
I have noticed a problem in Windows 10 Anniversary Update where the redesigned UAC prompt does not get focus and so it shows in the background. Unfortunately, it does not always show its flashing button on the Taskbar as the older UAC prompt used to reliably show. So it's a hidden window. If you Alt+Tab to it, it gets focus. Until then the menu will obviously not open. I don't think the bug is in Classic Shell.

If it happens frequently, you could try disabling the new UAC prompt.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\TestHooks
Change XamlCredUIAvailable to 0.

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and helped a little with Classic Shell's testing and usability/UX feedback.


Top
 Profile  
Reply with quote  
PostPosted: Mon Sep 12, 2016 2:28 pm 
Offline

Joined: Mon Sep 12, 2016 8:46 am
Posts: 3
Ah I see. I like UAC (for security and death prevention =D). I'd rather be more cautious on running apps via the Start Menu then.

Seems that Windows just gets less traditional which, in my opinion, is pissing the crap out of many Win32 developers.


Thanks anyways!


Top
 Profile  
Reply with quote  
PostPosted: Wed Sep 14, 2016 10:53 pm 
Offline

Joined: Mon Sep 12, 2016 8:46 am
Posts: 3
Hello again. I'm back.

Your solution on reverting UAC to the old one didn't work either. But I am certain that the fault goes to Windows as it also happens elsewhere outside the start menu. But I am also certain that it MOSTLY happens on the FIRST UAC prompt requested by the start menu (since I always start my Windows session that way).

Ivo you may want to see this issue optionally.


Thank you once again!


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group, Almsamim WYSIWYG Classic Shell © 2010-2016, Ivo Beltchev.
All right reserved.